$re = '/<(whoName)>(?!self\s*<).*?<\/\1>/';
$str = '<whoName>other</whoName>
<whoName>self</whoName>
<whoName>selfie</whoName>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);