$re = '/\b\d{2}_\d{2}\b|r\d/';
$str = 'Game Name 20_03 Starter Pack r6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);