$re = '/^(?=.*([a-z])$)|[a-zA-Z]+|[.!?]+/';
$str = 'many??? Woooooooooooords are';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);