import re
regex = re.compile(r"(?:http|https):\/\/((?:[\w-]+)(?:\.[\w-]+)+)(?:[\w.,@?^=%&:\/~+#-]*[\w@?^=%&\/~+#-])?", flags=re.MULTILINE)
test_str = ("https://developer.mozilla.org/es/\n\n"
"http://www.es.pornhub.com/\n"
"http://es.cumlouder.com/?nats=MTkzOC4xLjIuMi4wLjAuMC4wLjA\n"
"http://www.pornotube.com/orientation/straight/home/page/1\n"
"http://rubias19.com/\n"
"http://www.elreyx.com/\n"
"http://www.puritanas.com/\n"
"http://www.xvideos.com/\n"
"http://es.xhamster.com/\n"
"http://www.redtube.com/\n"
"http://es.cam4.com/\n"
"https://es.chaturbate.com/\n"
"http://new.bangbros.com/home.htm\n"
"http://www.brazzers.com/home/?nats=NDc1NzAzOjQ5MzoyNA,0,0,0,0\n"
"http://www.petardas.com/\n"
"http://www.poringa.net/\n"
"http://foxtube.com/\n"
"http://www.tubewolf.com/\n"
"http://www.youporn.com/\n"
"http://www.putalocura.com/\n"
"http://www.serviporno.com/\n"
"http://www.toropornohd.com/\n"
"http://www.aztepajas.com/\n"
"http://pornfun.com/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")