$re = '/&(?:[a-z\d]+|#\d+|#x[a-f\d]+)/';
$str = '<a>some link</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);