re = /^(?=.{8}$)[a-z0-9]{1,3}-[a-z0-9]{1,3}-[a-z0-9]{1,3}$/m
str = 'aa-99-99
99-23-bd
02-xx-04
ab-99-cz
sc-xd-49
99-xav-4
48-xyz-09
9-abc-01
xs-899-x
sss-99-x'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end