package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^|-)([^-\[]*(?:\[[^\]]+\])?)`)
var str = `DAS-1111[DR-Helpfull-R]-RUN--[121668688374]-N-[+helpfull_+string]
DAS-1111[DR-Helpfull-R]-RUN--[121668688374]
DAS-1111[DR-Helpfull-R]-RUN--[121668688374]-N-[+helpfull_+string]-anotherPart`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}