package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^Отлично! Надеюсь хорошо проведете время ;\) Начинай общаться 👉 (.+)$`)
var str = `Отлично! Надеюсь хорошо проведете время ;) Начинай общаться 👉 Добряк`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}