$re = '/!\[(.*?)\]\((.*?)\)/m';
$str = '.png)';
$subst = "\"<img alt='$1' src='$2' />\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;