package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`http:\/\/(.*?)\.png`)
var str = `http://sf.uploads.ru/qGhaC.png`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}