$re = '/\b\w+?(?=s?$)/m';
$str = '1 carrot
4 carrots';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);