$re = '/(?!^\()(?=\()/';
$str = '(1,1,A)(2,1,B)(1,1,C)(1,1,D)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);