$re = '/^((https?:)(\/\/\/?)([\w]*(?::[\w]*)?@)?([\d\w\.-]+)(?::(\d+))?)?([\/\\\\\w\.()-]*)?(?:([?][^#]*)?(#.*)?)*/mi';
$str = 'http://miguel:test@hoistedjs.com:599/moretesting?topic=data#migration/path';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);