import re
regex = re.compile(r"(?=<[^<]*\s+title=\"([^\"]*)\")|<\s*a[^>]*>([^<]*)(?:[^\/]*[^a]*[^>]*)(?<=[>])([^<]*)")
test_str = ("<p title=\"caca\"></p>\n"
"<p> </p>\n"
"<b>\n"
" \n"
" </b> \n"
"<B>title=\" gdd \"</B>\n"
"<i title=\"caca\">dsfgjdgfs</i>\n"
"<i title=\" boudin \">dsfgjdgfs</i>\n"
"<i> </i>\n"
"<i> </i>\n"
"<strong></strong>\n"
"<a>hello</a>\n"
"<i style=\"color: orange\"></i>\n"
"<a href=\"#\"> bizurot </a> !probleme \n"
"<o: class=\"ms-crap\"></o>\n"
"<a href=\"#\" title=\" kameleo \" > test </a> !probleme <a href=\"#\"> cramoute </a> !probleme \n\n"
"<a href=\"#\" title=\" banane \" > test <strong>hello</strong> asaidali </a><a href=\"#\"> hdsfahsdgf </a> !probleme </br>\n\n"
"<p>Not empty</p>\n"
"<p>Not \n"
" empty</p>\n"
"<i> \n\n"
" </i>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")