const regex = /^(?:(?=([^*:\n ]+[ ]?))\1){0,10}:/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?=([^*:\\n ]+[ ]?))\\1){0,10}:', 'gm')
const str = `Lorem ipsum dolor sit amet:, consectetur adipiscing elit. Nunc cursus nisl nec ornare sagittis. Aliquam imperdiet metus vel sapien congue pellentesque. Aliquam malesuada blandit tellus, quis interdum lacus feugiat at.
Proin tellus felis, aliquet at scelerisque quis, gravida vitae tellus. Cras iaculis aliquet libero et hendrerit: Cras nec consequat mauris. Fusce dolor elit, blandit a suscipit sed, vehicula eu quam. Donec eu tempus nunc. Vestibulum tincidunt et arcu at commodo. Quisque sodales convallis lobortis. Nullam maximus velit quis diam laoreet, sit amet dapibus quam semper.
Quisque eget metus ligula. Curabitur sit amet: nulla erat. Aenean at diam ut justo volutpat bibendum non ac nulla. Vestibulum tempor dolor odio, in ullamcorper nunc ullamcorper non. Nulla nec sagittis diam. Maecenas est mi, viverra vel ex et, ullamcorper dictum dui. Integer imperdiet mauris urna, eget venenatis lorem tincidunt at. Nunc elementum sed metus ut mattis. Nulla eu mattis velit. Pellentesque egestas id nulla a posuere. Sed quis nulla vitae odio malesuada accumsan. Vivamus rutrum rutrum orci et luctus. Phasellus at leo eget quam dignissim rhoncus quis ac sem. Nulla facilisi.
Vivamus ultricies tortor sit amet turpis blandit sollicitudin at at diam. Praesent placerat consequat convallis. In hac habitasse platea dictumst. Aenean justo diam, venenatis et ante ut, pharetra commodo augue. Proin sodales mi tempor lorem ornare, ac luctus diam eleifend. Nullam convallis ante vel consequat sagittis. Interdum et malesuada fames ac ante ipsum primis in faucibus. Quisque fringilla sem id nulla vulputate consectetur. Pellentesque sit amet enim vel leo finibus malesuada. Duis suscipit augue in orci venenatis ultrices. Pellentesque habitant morbi tristique senectus et netus et malesuada fames ac turpis egestas. Aliquam viverra at neque eget tincidunt. Nulla et tempus dolor. Donec semper, ligula vel egestas scelerisque, ex libero viverra ante, in mattis velit nunc in lacus.
Aliquam ut lorem vulputate, pretium quam ut, gravida massa. Donec in tortor diam. Suspendisse ac pellentesque eros. Suspendisse sed dui in ex aliquet scelerisque ut quis ipsum. Vestibulum ac sem sem. Fusce porta at nibh non imperdiet. Phasellus tempor scelerisque dolor, sed laoreet ligula scelerisque ut. Aliquam tincidunt augue et mauris vehicula, sit amet posuere orci scelerisque. Aliquam hendrerit eu sem ac suscipit.
Sed porta dictum hendrerit. Morbi eu tristique odio. Vivamus nisl nisl, sollicitudin quis purus eget, sodales tempor dui. Ut porttitor, purus a placerat mattis, erat eros porttitor sem, sit amet dictum elit orci eu ante. Cum sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Nullam luctus non tortor et bibendum. Mauris urna erat, pellentesque at eros condimentum, maximus bibendum nisl. Fusce est mauris, ultrices quis velit pulvinar, volutpat blandit nisi.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}