import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(k(?:ilogram|g)\\.*s*\\.*)\\W*(?:\\h+weight)?(?:\\h+(?:is|are))?\\W*(\\d[0-9.,]*\\b)|(\\d[0-9.,]*)\\W*(k(?:ilogram|g)\\.*s*\\.*)\\b";
final String string = "15kilograms fs s \n"
+ "kg 10 fe\n"
+ "something 10.5 kg-fef\n\n"
+ "11.55kg gfre\n"
+ "11.55-kg gfre\n"
+ "11.55 kg gfre\n"
+ "kg 11.25 gre\n"
+ "efewf kg 11 fweew\n"
+ "ewsfewf kg\n"
+ "55 few\n"
+ "kg-55.55 dwd\n"
+ "eeewegv kg 55.55 ee\n"
+ "fewfewff 10\n"
+ "kg feeee\n"
+ "smth. .15kg ewfcwe\n"
+ "something kilogram weight is 15.5\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}