package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:<[^\/]*?.*?<\/.*?>)|(:\/)`)
var str = `not feeling well today :/ check out this link <a href="http://example.com">http://example.com</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}