re = /(?<=Java[=:]'?[^']{0,100})[^',]/m
str = 'Java=\'ffyfufu\', Java=123
'
subst = '*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result