const regex = /\[([^\]]*)\]\(([^\s^\)]*)[\s\)]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[([^\\]]*)\\]\\(([^\\s^\\)]*)[\\s\\)]', 'g')
const str = `[sample link](http://example.com/) some text [sample link](http://example.com/ "with title")
[link name](http://stackoverflow.com/questions/40177342/regex-convert-a-markdown-inline-link-into-an-html-link-with-c-sharp "link to this question")`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}