use strict;
my $str = 'Cass. com., 5 janvier 2012, n° 12-45.644';
my $regex = qr/(Cass\.\s+com\.(?:,\s+(?:avis|QPC))?,\s+(\d{1,2})e?r?(?:\s| )+(\w+\.?)\s+(\d{4}),\s+n(?:°|°|o)s?(?:\s| )+(\d{2}-\d{2})\.?(\d{3}))/mp;
my $subst = '<renvoi type="CASS" refid="$5$6" jour="$2" mois="$3" annee="$4">$1</renvoi>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";