import re
regex = re.compile(r"^(.*?)\s?(?|(?:dek[ae]t\s(.+)\sradius\s(\d+(?:\.\d+)?)\s?(k?m))|(?:dek[ae]t\s(.+)))", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("rumah dekat ugm\n"
"rumah dekat ugm radius 3 km\n"
"rumah dekat ugm radius 500m\n"
"rumah dekat sindu park radius 5 km\n"
"rumah dekat sindu park radius 1.5 km\n"
"rumah dekat De Mata Trick Eye Museum radius 12 km\n"
"apartemen dekat UII radius 2 km\n"
"dekat ugm radius 3 km")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")