$re = '/[M]?\d+x\d+/';
$str = 'Screw М4х20 , DIN7985';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);