re = /(?<=token=)[^&\n]+/m
str = 'https://www.test.com/vgi-bin/tmpscr?cmd=_temp-out&useraction=commit&token=EC-1J942953KU425764F
https://www.test.com/vgi-bin/tmpscr?cmd=_temp-out&useraction=commit&token=EC-1J942953KU425764F&paymentid=PAY-12345K4776H687987R
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end