package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[6-9]\d{9}$`)
var str = `6123456789
3123456789`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}