$re = '/^(.{1,6}).*?\K\1/m';
$str = 'formatthere\'s a for in here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);