import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(?<tagName>\\w+)(([^<]*\\/>)|(.*?\\/(\\k<tagName>)>))";
final String string = " <child name = \"child_name1\" type = \"child_type1\"> <subchild id = \"1\" auth=\"auth1\">Value1</subchild> </child> <child name = \"child_name2\" type = \"child_type2\"> <subchild id = \"2\" auth=\"auth1\">Value2</subchild> <subchild id = \"3\" auth=\"auth2\">Value3</subchild> <subchild id = \"4\" auth=\"auth3\"></subchild> <subchild id = \"5\" auth=\"auth3\"/> </child>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}