re = /^(?:(25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9])(\.(?!$)|$|,|-)){3,4}(\*|(?:(25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9])(\.(?!$)|$|,)){4})?$/m
str = '10.80.212.195
10.80.212.*
10.80.212.0-10.80.212.255
9,9,9,9
05.05.05.05
1.20.250.251
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end