const regex = /\n(?=\d{3}\D)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\n(?=\\d{3}\\D)', 'g')
const str = `1223752, filed1Row1, filed2Row1, filed3
100% Row1
1223698 filed1Row2, filed2Row2, filed3
200\$ Row3`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);