$re = '/(.*[^-])(--[0-9A-Za-z-_]+)$/m';
$str = 'edit-field-media-file-0---X-chdeVIfw
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);