#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!(\d){3}(-| |)\1{2}\2\1{4})(?!666|000|9\d{2})(\b\d{3}(-| |)(?!00)\d{2}\4(?!0{4})\d{4}\b)"
Local $sString = "################" & @CRLF & _
"## Must match:" & @CRLF & _
"################" & @CRLF & _
"" & @CRLF & _
"123-45-4891" & @CRLF & _
"098-18-6564" & @CRLF & _
"123-45-4848" & @CRLF & _
"702-02-0202" & @CRLF & _
"001-14-0004" & @CRLF & _
"009958881" & @CRLF & _
"078-05-1120" & @CRLF & _
"009 95 8881" & @CRLF & _
"123-45-4891 is my ssn" & @CRLF & _
"my ssn is 123-45-4891" & @CRLF & _
"my ssn is 123-45-4891 ok?" & @CRLF & _
"my ssn is 123-45-4891." & @CRLF & _
"123454891 is my ssn" & @CRLF & _
"my ssn is 123454891" & @CRLF & _
"my ssn is 123454891 ok?" & @CRLF & _
"my ssn is 123454891." & @CRLF & _
"123 45 4891 is my ssn" & @CRLF & _
"my ssn is 123 45 4891" & @CRLF & _
"my ssn is 123 45 4891 ok?" & @CRLF & _
"my ssn is 123 45 4891." & @CRLF & _
"my ssn is:123-45-4891." & @CRLF & _
"my ssn is:123 45 4891." & @CRLF & _
"my ssn is:123454891." & @CRLF & _
"" & @CRLF & _
"################" & @CRLF & _
"## Must not match:" & @CRLF & _
"################" & @CRLF & _
"" & @CRLF & _
"# Same number sequences:" & @CRLF & _
"222-22-2222" & @CRLF & _
"444 44 4444" & @CRLF & _
"555555555" & @CRLF & _
"" & @CRLF & _
"# Telephone" & @CRLF & _
"1-234-567-8901" & @CRLF & _
"1-234-567-8901" & @CRLF & _
"1-234-567-8901 " & @CRLF & _
"1 (234) 567-8901" & @CRLF & _
"12345678901" & @CRLF & _
"" & @CRLF & _
"# Credit card " & @CRLF & _
"5500 0000 0000 0004" & @CRLF & _
"3400 0000 0000 009" & @CRLF & _
"3000 0000 0000 04" & @CRLF & _
"5500-1244-2232-0004" & @CRLF & _
"3400-1244-0000-009" & @CRLF & _
"3000-1244-1234-04" & @CRLF & _
"" & @CRLF & _
"# mixed (space), dash and (no space)" & @CRLF & _
"009 95-8881" & @CRLF & _
"009-95 8881" & @CRLF & _
"009 958881" & @CRLF & _
"00995 8881" & @CRLF & _
"" & @CRLF & _
"# Zero sequence" & @CRLF & _
"231-84-0000" & @CRLF & _
"231-00-7289" & @CRLF & _
"000-87-7289" & @CRLF & _
"231 84 0000" & @CRLF & _
"231 00 7289" & @CRLF & _
"000 87 7289" & @CRLF & _
"231840000" & @CRLF & _
"231007289" & @CRLF & _
"000877289" & @CRLF & _
"" & @CRLF & _
"# Starting with 9" & @CRLF & _
"908-78-0485" & @CRLF & _
"908 78 0485" & @CRLF & _
"908780485" & @CRLF & _
"" & @CRLF & _
"# Random Numbers" & @CRLF & _
"1234567890112371298739872891738912738937289d712897381297381927d3128937893d7218947d1892742189duc89789v127c897412987893c12893c79" & @CRLF & _
"122-426-389" & @CRLF & _
"187-5-43212" & @CRLF & _
"187-0-43212" & @CRLF & _
"2423-45-6789" & @CRLF & _
"myssnnumberis123-45-4891ok?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")