// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?P<asset>[A-Z]+)_(?P<side>C|L|R)_(?P<object>[A-Za-z0-9]+)_(?P<type>grp|ctrl|jnt|jntEnd|geo|loc|clstr|cls|crv|nbs|ikhl|cloth|nCloth|nucleus|ncls|foll|flc|hair|nHair|dist)$").unwrap();
let string = "GORDON_L_upperLeg_jnt";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}