re = /^(?=.*Generated at)[[:space:]]*[^[:space:]*]/m
str = '- * Generated at 2018-11-21
+ * Generated at 2018-11-23
+ * This line is important! Although it starts with a *
+ * Generated at 2018-11-23
+ * This line should be important, but there it contains a "Generated at"...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end