$re = '/#[\wа-яёА-ЯЁ]+[\w-]*/';
$str = '#test kjhrtjhe #TEST t #e kwkw#itttrrrtos hjer ret ert#erwere jkerjkwer #тест #гоа #34343 #ХЕШ #хёш #ХОРОШО вввв';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);