const regex = /("")([^<>]*?)("")(?=(?:[^>]*?(?:<|$)))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('("")([^<>]*?)("")(?=(?:[^>]*?(?:<|$)))', 'gm')
const str = `"FRENCH","11.03.2022 13:36","DocumentType.APPROVAL_AV","Approbation de la personne responsable du marché (""RdM"")"
"SPANISH","11.03.2022 13:36","DocumentType.APPROVAL_AV","Aprobación del o de la responsable de la orden"
"ENGLISH","11.03.2022 13:36","DocumentType.ARGE_DECLARATION","Declaration of the consortium (""ARGE"")"
"FRENCH","11.03.2022 13:36","DocumentType.ARGE_DECLARATION","Déclaration du groupement"
"SPANISH","11.03.2022 13:36","DocumentType.ARGE_DECLARATION","Declaración del consorcio (en Alemania “ARGE”)"
"ENGLISH","11.03.2022 13:54","appHelpSignpostText","If you have any technical issues, please do not hesitate to contact us personally through the following channels:<br /><br /><a href=""https://test.com/"" target=""_blank"">{{downloadIcon}}Guide</a> to help you enter your request."
"FRENCH","11.03.2022 13:54","appHelpSignpostText","Si vous rencontrez des difficultés techniques, n’hésitez pas à nous contacter personnellement via les canaux suivants : <br /><br /><a href=""https://test.com/"" target=""_blank"">{{downloadIcon}}Guide</a>, pour vous aider à saisir votre demande."
"SPANISH","11.03.2022 13:54","appHelpSignpostText","Si tiene dificultades técnicas, no dude en ponerse personalmente en contacto con nosotros o nosotras a través de los siguientes canales:<br /><br /><a href=""https://test.com/"" target=""_blank"">{{downloadIcon}}Guía</a>, que le servirá de ayuda para introducir su solicitud."
"ENGLISH","11.03.2022 13:36","appraisalAndConsultingRadio","Consulting contracts for <b>Test Service (TeS)</b>"
"FRENCH","11.03.2022 13:36","appraisalAndConsultingRadio","Contrats de conseil pour <b>Test Service (TeS)</b>"
"ENGLISH","11.03.2022 13:36","argeRadio","Consortium (called ""Arge"" in German)"
"FRENCH","11.03.2022 13:36","argeRadio","Groupement momentané d’entreprises (groupement)"
"SPANISH","11.03.2022 13:36","appraisalAndConsultingRadio","Contratos de asesoramiento para <b>Test (Tst)</b>"
"ENGLISH","11.03.2022 13:54", "sustainabilitySignpostText","The goal of sustainable management is to ensure that our earth is worth living on for future generations.<br /><br />More about GIZ’s sustainability activities can be found in the IDA communities <a href=""https://test.com/"" target=""_blank"">{{purIcon}}Corporate Sustainability""</a> (more general) or <a href=""https://test.com/"" target=""_blank"">{{purIcon}}Sustainable Procurement</a> (especially for procurement). There you will find extensive information and handouts to help you make our planet a little more climate-friendly.<br /><br />And this begins not least in procurement."
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}