package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\{.*?:\")*(\"})*`)
var str = `[{"acks":"6"},{"acks":"17"},{"acks":"888"}]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}