$re = '/[^<>()\[\]\\\\.,;:\s@"]+@[^<>()\[\]\\\\.,;:\s@"]{3}\[\.\][^<>()\[\]\\\\.,;:\s@"]{2}/m';
$str = 'asd@asd[.]gr
*@xxx[.]co';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);