package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^&]*\s`)
var str = `a simple string that may contain this & that but I want it to skip &&. Do you follow? `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}