$re = '`(?:(?:^|[^&])&(?:[^&]|$)|[^&])+`';
$str = 'a simple string that may contain this & that but I want it to skip &&. Do you follow? ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);