re = /(?:(?!&&|(?<=&)&).)+/
str = 'a simple string that may contain this & that but I want it to skip &&. Do you follow? '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end