import Foundation
let pattern = #"(?<=v=|/)\w{10,11}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
https://www.youtube.com/watch?v=MI9tFPT6yK4&t=17s
https://www.youtube.com/watch?v=48Y_jWQDDiw
https://www.youtube.com/MI9tPtdas5
https://www.youtube.com/9MI9tPtdas5
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)