package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<a[^>]+href=["'](?:https://www\.example\.com/page|/page)`)
var str = `<a href="https://example.com/page">first</a>
<a href="/page">second</a>
<a href="https://www.example.com/page">third</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}