re = /,(?="[^"\\]*(?:\\.[^"\\]*)*")/m
str = '"","1114356033020-0011,- [BRACKET],1114356033020-0017,- [FRAME],1114356033020-0019,- [CLIP],1114356033020-0001,- [FRAME ASSY],1114356033020-0013,- [GUSSET],1114356033020-0015,- [STIFFENER]","QH20426AD3 [RIVET,SOL FL HD],UY510AE3L [NUT,HEX],PO41071B0 [SEALING CMPD],LL510A3-10 [\\"BOLT,HI-JOK\\"]"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end