re = /(.)(?<=^(?:(?!\1).)*\1(?=(?:(?!\1).)*\1(?:(?!\1).)*$))/m
str = 'asdf
fdas
asds
d fm
dfaa
aaaa
aabb
aaabb'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end