$re = '/\bVALUES\s*\((\s*(?:N\'[^\']*\'|\w+))(?:,(?1)){12}\K,(?1)/m';
$str = 'INSERT member (member, prename, name, street, postalcode, town, tel1, tel2, fax, bem, anrede, salutation, email, name2, name3, association, project) VALUES (2005, N\'John\', N\'Doe\', N\'Street 4711\', N\'1234\', N\'Town\', N\'1234-5678\', N\'1234-5678\', N\'1234-5678\', N\'Leader\', NULL, N\'Dear Mr. Doe\', N\'a@b.com\', N\'This is the text i want to delete\', N\'Name2\', N\'Name3\', NULL, NULL);```';
$subst = "<WHATEVER_YOU_NEED>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;