use strict;
my $str = '"observação"';
my $regex = qr/"(.*?)"/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";