import re
regex = re.compile(r"((?<start_date>\d{4}){1}.*?)?(?<end_date>\d{4})$", flags=re.MULTILINE)
test_str = ("May 30, 1949, published 1979\n"
"May 30, 1949 and 1951, published 1979\n"
"May 30, 1949, printed 1980\n"
"May 30, 1949, print executed 1988\n"
"May 30, 1949, prints executed 1988\n"
"published 1940\n"
"August or September 1908\n"
"May 30, 1949")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")