#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9<>=](?!.*?[^\n0-9]{2}).*?[0-9]$"
Local $sString = "1-2" & @CRLF & _
"-2" & @CRLF & _
">3" & @CRLF & _
"3>4" & @CRLF & _
"3>5>6" & @CRLF & _
"6>" & @CRLF & _
"5-" & @CRLF & _
"1-3-4-5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")