re = /(?:(^(?:[^A-Z]+-)?)|((?:-[^A-Z]+)?$)|((?:[^A-Z]*)?[A-Z]))/m
str = 'foo-AB(-16)CDE-bla
asaABC-bla
DEF'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end