$re = '/^(?![^-\n]*-[^-\n]*-)[A-Za-z0-9-]+$/m';
$str = 'Abc-234
Abc-234-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);