// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)(?|
c\
(?P<catcher>.{2,}?)
\ b\
|
c\ & \ b\
(?P<catcher>.+))").unwrap();
let string = "
c Soumya Sarkar b Rubel Hossain
c Imrul Kayes b Mosaddek Hossain
c & b Sodhi
c Anderson b Boult
c †Lenton b Cummins
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}